jeudi 29 novembre 2007

Acheter sa solution de TOIP en ligne

Aastra Matra propose désormais via son site internet Aastraonline.com une offre de TOIP à destination des TPE-PME Françaises.

Cette offre de type semi-hébergée est composée de trois éléments :

- le logiciel de ToIP Aastra Link (basé sur Asterisk)
- un serveur Aastra Box
- des terminaux SIP de la gamme 5xi.


Le client acquiert la partie matériel, le logiciel est mis à sa disposition sous forme d’un abonnement par utilisateur et par mois sans engagement de durée.

Aastra Link est livré avec HUD (Heads Up Display), une application de Convergence Téléphonie Informatique pour la gestion de la téléphonie depuis un ordinateur et trixNet, un service d’appels gratuits entre deux sociétés membres de la communauté façon Skype.

http://www.aastraonline.com/

mardi 27 novembre 2007

Configurer un switch OmniStack 6200 ALCATEL

Le premier commentaire de ce blog concernait le manque d’informations concernant la configuration du switch ALCATEL 6200.

Ci-dessous un exemple de configuration à implémenter dans un environnement VOIP :

Configurer un VLAN
Console (config) # vlan database
Console (config-vlan) # vlan 100

Affecter une interface à un VLAN
Console (config) # interface ethernet 1/e16
Console (config-if) # switchport access vlan 100

Configurer la qualité de service
Console(config)# qos Active la QOS
Console(config)# class-map Nom classe match-all
Console (config)# class-map Nom classe
Console (config-cmap)# match access-group Nom acces list
Console(config)# class-map Nom classe match-all

Console (config)# policy-map policy1
Console (config-pmap)# class Nom classe access-group Nom acces list
Console (config-pmap)# class Nom classe
Console (config-pmap-c)# trust cos-dscp
Console (config-pmap)# set dscp 46
Console (config-if)# service-policy input policy1

Console (config)# policy-map policy1
Console (config-pmap)# class Nom classe
Console (config-pmap-c)# police 124000 9600 exceed-action drop

Affectation à la classe d’un debit possible
Console (config)# qos map dscp-dp 46 to 5 match QOS COS

Mise en place des files d’attente COS 5 file 1
Console(config)# wrr-queue cos-map 1 5


Affectation des mécanismes au niveau d’une interface
Console(config)# interface ethernet 1/1
Console(config-if) service-policy input
Console(config-if) qos trust

J’espere ne rien avoir oublier ce type d’équipement ne m’étant je l’avoue pas familier.

mardi 20 novembre 2007

Un outil pour gerer vos comptes SIP : MY SIP SWITCH


Vous possédez plusieurs comptes SIP et vous souhaitez pouvoir les utiliser avec un seul téléphone My SIP Switch est fait pour vous.

Ce logiciel Open Source basé sur la signalisation SIP vous permet de gérer facilement vos differents comptes.
Il comprend: SIP Stack, SIP Registrar, SIP Stateful proxy, STUN, ainsi que des modules spécifiques

Il est également capable de faire de la redirection SIP/PSTN, SIP/GSM ou SIP/SIP.
Ce service est entièrement gratuit.
http://www.mysipswitch.com/

Obtenir le code source:
http://www.codeplex.com/mysipswitch

samedi 17 novembre 2007

Les mécanismes de sécurité mis en place sur un switch CISCO 3560

DHCP Snooping
La fonctionnalité DHCP snooping securise le reseau en filtrant les messages DHCP changés sur le LAN.
Elle constitue une parade aux attaques visant à prendre la place du serveur (DHCP Spoofing) ou à épuiser le pool mis en place.
Le switch contruit et maintient une table comportant les éléménts suivants : MAC address, IP address, lease time, binding type, VLAN number, and interface information

Pour l'activer :
Switch(config)# ip dhcp snooping
Switch(config)# ip dhcp snooping vlan 100
cette commande permet d'indiquer le vlan concerné
Switch(config)# no ip dhcp snooping information option
dans ce cas on n'active pas les option étendues.

Au niveau d'un port limiter le nombre de paquets emis par seconde est possible.
Switch(config)# interface gigabitethernet0/1
Switch(config-if)# ip dhcp snooping limit rate 100

Sécurisation des ports
Il est possible de restreindre le nombre d'adresses MAC possibles sur chacun des ports. Ce faisant on se protége des attaques par MAC flooding

Pour l'activer :

Switch(config)# interface gigabitethernet0/1
Switch(config-if)# switchport mode access
Switch(config-if)# switchport port-security
Switch(config-if)# switchport port-security maximum 3
dans cette configuration 3 adresses sont possibles
En présence de VLAN il est possible de les répartir
Switch(config-if)#switchport port-security maximum 2 vlan 3
Switch(config-if)#switchport port-security maximum 1 vlan 4

Il est en outre possible de parametrer des durées
Switch(config-if)# switchport port-security aging time 2
Switch(config-if)# switchport port-security aging type inactivity
Switch(config-if)# switchport port-security aging static


Limiter les requettes ARP
Pour se prémunir d'un DOS (deni of service) il est recommander de limiter au niveau de chacun des ports les requettes ARP ansi que leurs réponses

Pour l'activer :

Switch(config)#ip arp inspection limit rate 70
Dans ce cas la valeur 70 correspond au nombre de paquets par seconde.

dimanche 11 novembre 2007

Un peu de sécurité

On parle beaucoup de sécurité en VOIP et TOIP quels sont les risques ?

Les communications XOIP semblent moins sécurisées que celles passées à partir d’un poste analogique. Aux risques inhérents à la téléphonie traditionnelle (dégradation de l’infrastructure physique) il convient d’ajouter tous les risques auxquels sont exposés les réseaux de données.

Le flooding, la transmission de paquets anormaux sont des phénomènes qui peuvent altérer la qualité des échanges.

Le détournement d’une communication call hijacking s’opérant de façon logiciel suscite un sentiment de peur qui n’existe pas en téléphonie traditionnel.

La composante sécurité réseau hier quelques peu délaissée doit désormais être prise en compte dans le cadre d’un projet de téléphonie sur IP.

Heureusement de très nombreuses solutions techniques existent.

Au niveau des switchs l’authentification des ipphones via leur adresse MAC, l’impléméntation de VLAN.

La mise en place des fonctionnalités IPS et ou Firewall dans les routeurs CISCO.

Pour les sites plus important la mise en place de boitier Appliance UTM.

Et enfin le cryptage des flux RTP.

vendredi 9 novembre 2007

FIREFLY le softphone FLESHTEL







FLESHTEL vient de publier la version 3.0.2 de son softphone Firefly.

Celui ci permet la gestion de plusieurs communications simultanées.
Compatible VISTA il devrait l'etre à terme avec OUTLOOK.
Il utilise le protocol SIP ainsi que les codecs Ilbc et G.711u/a
http://www.freshtel.net/
Le télécharger


dimanche 4 novembre 2007

SIPdefense une appliance qui protége les communications SIP

Comment sécuriser les communications VOIP basées sur le protocole SIP ?
Une solution existe désormais utiliser
SIPdefense une appliance de sécurité dédiée aux applications SIP lancée par la société CheckPhone.

« SIP se développe de plus en plus dans les entreprises, notamment grâce aux raccordements SIP qui, proposés par les opérateurs alternatifs, permettent de remplacer leurs lignes TDM classiques. Nous leur proposons une solution complète permettant de sécuriser l'ensemble de leurs sites », explique Arnaud Lemoine, chef produits de CheckPhone.

SIPdefense comme c’est le cas de la majorité des appliances regroupe plusieurs fonctionnalités :

* Un proxy SIP (traitement de la signalisation).

* Un proxy RTP ( traitement des paquets )

* L'analyse protocolaire ainsi qu’un filtrage stateful inspection relatif aux données de session.

* Il propose en plus la traduction NAT ainsi que le chiffrement (signalisation et, bientôt, parquets).

* L'authentification et le support Radius font également partie de ses fonctionnalités.

A noter que cet équipement sera distribué par les principaux intégrateurs du marché : Orange Business Services, NextiraOne ou AmecSpie.

Son prix s’établi à 3500 euros pour 25 utilisateurs.

jeudi 1 novembre 2007

Utiliser des Analog Phone Gateway CISCO.



En environnement VOIP Cisco il est possible pour minimiser les couts de conserver les postes téléphoniques classiques, les modems et les télécopieurs. Pour ce faire on connecte ceux-ci à des Analog Phone Gateway.

En fonction du monbre d’appareils à connecter on s’orientera vers le modèle VG224 (24 postes) ou le modèle VG248 (48 postes).

Concernant les fax ces deux équipements utilisent la fonctionnalité fax relay CISCO.

Ci-dessous l’architecture mise en place :