mardi 12 juin 2007

Mettre en œuvre les classes de service

Pour distinguer les différent type de flux les paquets IP sont colorés en entrée sur l’interface LAN. CB-MARKING
Cette opération se fait soit en utilisant le champ DSCP soit à l’aide d’accès list.


Ci dessous un exemple sur un routeur CISCO :
Le flux D1 correspond aux paquets IP étant marqués avec le champ DSCP AF32
class-map match-any D1
match ip dscp af32

Le flux D1 correspond aux paquets correspondant aux critères de l’accès list D1
class-map match-any D1
match access-group name D1
ip access-list extended D1
remark -- Traffic D1 ---
permit tcp any host 141.2.87.53 eq www
permit tcp any host 141.22.92.53 eq www

Un mixte des 2 pour les flux voix
class-map match-any VOIX
match access-group name VOIX

ip access-list extended VOIX
permit ip any any dscp ef

En sortie sur l’interface WAN on attribue à chaque classe une bande passante. En cas de dépassement du % de base passante allouée un mécanisme de déclassement des paquets IP est mis en œuvre.
On procède alors au remplacement du champ DSCP ( AF31 vers AF32 ). CB-POLICING

Le routeur gère plusieurs files d’attente en fonction de la bande passante attribuée. CB Weighted Fair Queuing.
Les paquets sont extraits des files d’attente afin de les transmettre en fonction de leur priorité.
A noter que les paquets VOIX sont transmis de façon prioritaire grâce à un mécanisme de priorité absolue ( LLQ Low Latency Queuing)
.
A chaque file d’attente est associé un mécanisme WRED Weighted Random Early Detected dont le but est de faire ralentir les applicatifs afin de prévenir la congestion.

A noter que la mise en place de QOS au niveau d’un routeur doit se faire en prenant en compte à la fois l’aspect data et l’aspect voix.

0 commentaires: