mercredi 30 mai 2007

Soft phone vous avez dit soft phone

Pour utiliser la TOIP 2 alternatives s’offrent à nous :
Utiliser un IP phone.
Utiliser un soft phone.

Un soft phone est un logiciel qui permet d’émuler au niveau d’un ordinateur un téléphone IP.
Il existe 3 types de programmes :
1 Ceux qui sont indépendants du provider.
2 Ceux qui sont préconfigurés et qui ne permettent de communiquer qu’avec un correspondant utilisant le même type de matériel les plus connu étant SKYPE et GIZMO.
3 Les messengers qui outre la fonction chat permettent les communications téléphoniques : NETMEETING, Messenger

Liste non exhaustive

Au niveau des switchs la QOS est mise en place en utilisant des access list.

L'IOS des switch 2950 ne gerant pas correctement ce type de configuration il est indispensable de connecter les PC utilisant des soft phone sur un autre type de matériel

samedi 26 mai 2007

Mettre en place de la QOS sur les switchs CISCO

Il est indispensable de configurer les switchs afin que ceux ci prennent en charge la qualité de service.
Nous avons definit ce qu’est le champ COS 5 ( niveau 2 ) il existe au niveau 3 ( niveau IP ) un champ qui permet de gerer lui aussi la qualité de service : le champ DSCP. Nous en parlerons la semaine prochaine.

Nous devons afin de gerer la qualité de service de bout en bout mettre en place une table de correspondance.

Sur un switch cisco 2950 on utilise la commande :
Switch2950(config)# mls qos map cos-dscp 0 8 16 26 32 46 48 56

Visualiser la table crée :
Switch2950#show mls qos maps

Dscp-cos map:

dscp: 0 8 10 16 18 24 26 32 34 40 46 48 56

-----------------------------------------------

cos: 0 1 1 2 2 3 3 4 4 5 5 6 7

Cos-dscp map:

cos: 0 1 2 3 4 5 6 7

--------------------------------

dscp: 0 8 16 26 32 46 48 56

On constitue ensuite 4 files d'attente en associant à chacune d'elle des valeurs COS :
Switch2950(config)# wrr-queue cos-map 1 0 1
Switch2950(config)# wrr-queue cos-map 2 2 4

Switch2950(config)# wrr-queue cos-map 3 3 6 7
Switch2950(config)# wrr-queue cos-map 4 5

Le premier chiffre correspond au numero de la file d’attente les suivants aux valeurs COS.

Dans notre cas la file 4 est associé au champ cos 5.

On affecte une taille à chacune des files avec la commande :

Switch2950(config)# wrr-queue bandwidth 60 10 30 0

On termine en mettant en oeuvre les mécanismes ci dessous dans chacune des interfaces :
Switch2950(config)# int FastEthernet0/4
Switch2950(config-if)# mls qos trust cos

mercredi 23 mai 2007

Business Together with Microsoft

Orange Business Services et Microsoft viennent d’annoncer le lancement d’une gamme commune de services dénommée Business Together.

Cette gamme permettra d’associer les services de convergence ip et réseaux de l’opérateur avec les briques de communication unifiées développées par Microsoft :

Office communication Server 2007, Exchange Server 2007, Forefront, Office sharepoint Server ….

Les outils ci dessus permettent d’optimiser et de simplifier l’usage des outils de communication que sont l’e-mail, la messagerie instantanée, la Visio et la téléphonie sur IP ce à partir de n’importe quel type de terminal.

mardi 22 mai 2007

Configurer les ports d'un switch 2950

Ci dessous la configuration à mettre en place sur un switch 2950
Le VLAN VOIX étant le 100

Port Dédié

interface FastEthernet0/2
description ***VERS IP PHONE****
switchport access vlan 100
switchport mode access
switchport nonegotiate
no ip address
mls qos trust cos
no cdp enable

Port mutualisé le port est configuré en TRUNK

interface FastEthernet0/3
description *** Port LG IP phone + PC ***
switchport trunk allowed vlan 1,100
switchport mode trunk
switchport nonegotiate
no ip address
logging event trunk-status
mls qos trust cos
no cdp enable
spanning-tree portfast trunk

Dans la mesure ou il est difficile de connaître le raccordement physique en place la configuration numero 2 est à privilégie.

Elle permet en outre de réduire le nombre de ports utilisés.

A noter que l'IPBX est à raccorder sur un port dédié.

Plus d'informations :

Cliquez sur ce lien

IP PHONES utilisant les logiciels MICROSOFT




Microsoft vient d’annoncer son intension de s’associer avec 9 constructeurs dont SAMSUNG, LG-NORTEL et NEC afin de lancer une série de téléphones IP ou USB fonctionnant aves ses logiciels Office Communications server 2007 et Office Communicator 2007.
La stratégie de Microsoft vie à grouper sur un unique terminal les communications téléphoniques, le traitement des emails, la messagerie instantanée.


La firme américaine se donne trois ans pour convaincre le public et les différents acteurs du domaine d’opter pour son concept de stratégie de communication unifiée.

Pour en savoir plus : lien

samedi 19 mai 2007

Comment connecter les ip phone ?

Comment connecter les ip phones sur le lan ?
il existe 2 solutions

1 les connecter sur des ports dédiés dans ce cas chacun des port n’appartient qu’à un unique VLAN :le VLAN voix.
Cette solution consomme beaucoup de ressources au niveau switch.

2 Chaîner sur un méme port un micro-ordinateur et l’ip phone.
Le téléphone ip se comporte dans cette architecture comme un mini switch. Il lui appartient de marquer les trames éthernet en ajoutant les référence des VLAN ainsi que le champ COS.
Au niveau du switch celui-ci est configuré en mode trunk.

mercredi 16 mai 2007

802.3af power over ethernet

La norme 802.3af définit l’alimentation électrique de l’IP Phone via le port éthernet du Switch.
Elle permet de fournir un courant électrique de 48volts et d’une puissance maximale de 15 watts permettant de faire fonctionner des terminaux IP.
Cette fonctionnalité permet de réduire le nombre de câbles et d’alimenter des équipements dans des zones ou les prises électriques sont rares.
Le switch cisco 3750 est conforme à cette norme.
Le surcoût induit par ce type de matériel est à prendre en compte dans le coût d’un projet TOIP.

mardi 15 mai 2007

La norme 802.1p

La norme 802.1p est une extension de 802.1q en effet elle permet de définir le rôle et les valeurs des trois bit du champ priority (COS).
Elle est utilisée soit sur des switchs de niveau 2 ou de niveau 3 ( switch gérant des fonctions de routage inter VLAN). Elle permet de gérer des priorités et des files d’attente au niveau des switch.

Les valeurs possibles du champ COS sont les suivantes :
1 arrière plan
2 service économique ou standard
0 service best effort
3 service maximum (business critical)
4 streaming application à charge contrôlée
5 multimédia interactif (voice)
6 voix interactive
7 critique (network critical)

Certains switch n’étant pas capable de gérer la priorisation 802.1q il convient d’effectuer le bon choix.
Au niveau distribution on installera par exemple des Cisco 2950 ou des Nortel 470
Au niveau distribution des Cisco 3550, 3560 ou 3750, des Nortel gamme 5500

dimanche 13 mai 2007

La norme 802.1Q

Maintenant que nous avons définit ce que sont des VLAN intéressons nous à leur traduction au niveau trame.
Au niveau de la trame éthernet on insère conformément à la norme 802.1q 4 octets qui permettent de coder le VLAN mais aussi d’insérer une priorité en utilisant le champ TOS.

Les 2 premiers octets sont utilisés pour identifier le protocole de la balise insérée. Leur valeur est fixée à 0x8100.

Le champ identifiant de VLAN utilisant 12 bits il est possible d’adresser 4096 VLAN.


vendredi 11 mai 2007

Creation d’un VLAN sur switch NORTEL baystack 450 / 470

L’administration utilise des menus qui apparaissent après avoir saisi CTRL Y

Switch Configuration > VLAN Configuration > VLAN Configuration
VLAN Configuration

Create VLAN: [ 1 ] VLAN Type: [ Port-Based ]
Delete VLAN: [ ] Protocol Id (PID): [ None ]
VLAN Name: [ VLAN #1 ] User-Defined PID: [ 0x0000 ]
Management VLAN: [ Yes ] VLAN State: [ Active ]

Port Membership
1-6 7-12 13-18 19-24 25-26
------ ------ ------ ------ ------

Unit #1 UUUUUU UUUUUU UUUUUU UUUUUU
Unit #2 TUUUUU UUUUUU U
Unit #3 UUUUUU UUUUUU UUUUUU UUUUUU TT


KEY: T = Tagged Port Member, U = Untagged Port Member, - = Not a Member of VLAN
Use space bar to display choices, press or to select choice.
Press Ctrl-R to return to previous menu. Press Ctrl-C to return to Main Menu.

jeudi 10 mai 2007

Définition des VLANS

Un VLAN est un groupement logique d’utilisateurs ou de ressources connectées à des ports clairement définis sur un Switch.
Chaque VLAN définit un domaine de broadcast virtuel. Lorsque des trames sont diffusées en broadcast elles ne sont transmises qu’aux ports appartenant à un VLAN.
Avantage de la mise en place de VLAN :
- augmentation du nombre de domaines de broadcast tout en réduisant leur taille
- Augmentation du niveau de sécurité : les pc connectés dans différents VLAN ne peuvent pas communiquer entre eux nativement.
- Mise en place de groupes logiques indépendants de la situation des utilisateurs.
- Facilitent la gestion du Lan en facilitant les changements, la création des utilisateurs, leur suppression.


La mise en place d’un VLAN s’effectue en 3 étapes
1 La creation du VLAN
2 Son nommage
3 L’affectation des ports dans celui ci

Ci dessous un exemple sur un switch CISCO 2950
Creation du vlan
2950#conf t
Enter configuration commands, one per line. End with CNTL/Z.
2950(config)#vlan 100
2950(config-vlan)#name TOIP
2950(config-vlan)#^Z
2950#

Visualisation des VLAN
2950#show vlan

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/4, Fa0/10, Fa0/14, Fa0/17
100 TOIP active Fa0/12
950 VLAN0950 active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

Affectation d’un port
2950#conf t
Enter configuration commands, one per line. End with CNTL/Z.
2950(config)# interface FastEthernet0/7
2950(config-if)# switchport access vlan 100
2950(config-if)#exit

En régle géneral à chaque VLAN on fait correspondre un subnet ip. En TOIP les Ip Phones sont raccordés dans un même VLAN : le VLAN 100

mercredi 9 mai 2007

Qu'est ce qu'un switch ?

Un switch ou commutateur ethernet est un équipement de niveau 2 qui manie des trames.
Contrairement à un hub qui repete les trames qu’il recoit sur tous les ports il essaye de minimiser les envois inutiles sources de collisions.
Pour ce faire il construit une table de commutation en associant les adresses MAC avec les ports permettant de les atteindre.Lorsque l’adresse de destination d’une trame n’est pas dans sa table il la transmet sur tous les ports en excluant celui sur lequel la trame lui est parvenue.





Tout comme un hub il fournit un seul domaine de diffusion. A chaque port est associé un domaine de collision.

Il existe 3 methodes de switching :
*Store and Forward le switch attend d’avoir recu tous les bits de la trame avant de la faire suivre
* CUT Through le switch fait suivre la trame des qu’il a recu l’adresse de destination
* FragmentFree la trame n’est transmis qu’après la réception des 64 premiers bytes

mardi 8 mai 2007

Pas de concentrateur ( hub ) sur le LAN

Les hubs ne sont pas compatibles avec la téléphonie sur IP. Outre le fait qu’ils ne savent pas gérer la qualité de service chacun des équipements qui leurs sont raccordés partagent le même domaine de diffusion ainsi que le même domaine de collision.

La diffusion sur tous les ports des trames Ethernet transmises par une machine induit bien souvent de nombreuses collisions qui se traduisent par des lenteurs.

Dans le cadre d’un projet TOIP ou VOIP il est indispensable de remplacer ce type de matériel par des Switch ou commutateurs réseau.

lundi 7 mai 2007

jeudi 3 mai 2007

Quelques informations concernant le câblage

La norme ISO 11801 définit depuis 1994 le câblage a mettre en œuvre dans un bâtiment.
L’architecture définie est l’étoile à trois niveaux :
- répartiteur général
- répartiteur principal
- sous répartiteur d’étage

Le nombre maximum de postes de travail raccordés à un répartiteur ne peut excéder 150.
Un poste de travail doit comporter au minimum 2 prises.
Les supports définis sont la paire symétrique ainsi que la fibre optique.
La connectique concernant les câbles doit être de type RJ45 concernant les fibres de type ST ou SC.
Pour la distribution horizontale on utilise du câble 4 paires dont l’impédance est de 100 ohms.
Les liaisons définies sont les classes A,B,C,D,E et F.

La famille des câbles à paires torsadées se décline en 4 sous familles
- les câbles UTP non blindés et d’impédance de 100 ohms
- les câbles FTP écrantés et d’impédance de 120, 100 ohms
- les câbles SFTP blindés et d’impédance de 100 ohms
- les câbles S-STP blindés par paires 100 ohms

Il existe en suite plusieurs catégories de câbles selon les exigences d'utilisation:

- Catégorie 1: Câble téléphonique traditionnel (transfert de voix mais pas de données)
- Catégorie 2: Transmission des données à 4 Mbit/s maximum
...
- Catégorie 5: 100 Mbits/s maximum
- Catégorie 5E: 1000 Mbits/s maximum
- Catégorie 6: de 1000 Mbits/s à 6 ou 7Gbits/s

Ne pas confondre catégorie de produit et classe même si on parle ce câble catégorie 6 classe E.
Pour valider une application classe E il est nécessaire de s’assurer que tous les composants sont certifiés catégorie 6.
En règle générale la longueur maximum n’excède pas 100 mètres.



Au niveau des connecteurs RJ45, il existe 2 schémas de câblage: le TIA/EIA 568A et TIA/EIA 568B.


La différence entre ces deux câblages réside dans le croisement des fils de réception et de transmission.


Précautions de câblage
Le rayon de courbure du câble ne doit pas être trop important
Le détorsadage des paires doit être au maximum de 13mm pour un câble de catégorie 5
Le degainage du câble doit être réduit au maximum ( entre 30 et 60mm)
A chaque extrémité du câble les écrans doivent être raccordés à la masse
Pour un câble écranté l’écran doit être conservé le plus prêt possible du point de connexion.

mercredi 2 mai 2007

Un peu de stratégie

Certaines entreprises voulant réduire leur cout se lancement dans la téléphonie sur IP sans en appréhender toutes la complexité.

Pour que ce type de solution fonctionne il est nécessaire que les très nombreux équipements mis en œuvre fonctionnent de façon optimale.


Les clients que j’accompagne mettent en œuvre 2 démarches.

1 Celle du tout tout de suite pour ce faire ils procèdent à une refonte totale de leur architecture :

Mise en œuvre de switchs ou remplacement de ceux ci, reconstruction d’un nouveau réseau de données ( nouvelles liaisons, remplacement des routeurs).

Mise en place d’un nouveau câblage informatique sur certains sites.

2 Celle de la mise à niveau progressive des équipements : mise à niveau progressive des équipements LAN, optimisation du WAN.

Le cout de certain équipement reste important voici quelques exemple :

switch cisco
switch nortel
routeur cisco

Il est donc nécessaire d’agir dans le cadre d’une démarche pragmatique.